public marks

PUBLIC MARKS from bacon with tags diretórios & xoops

23 January 2007

instalando e substituindo diretórios

bem, aqui estou eu de novo.. agora com outro erro no phpmyadmin. recebi um servidor novo, onde instalei o debian. instalei tudo, xampp e xoops. coloquei o conteúdo que estava em outro servidor, mas quanto tento restaurar aquele banco que me mandou, dá o seguinte erro: fatal error: allowed memory size of 8388608 bytes exhausted (tried estou allocate 3429106 bytes) in /opt/lampp/phpmyadmin/libraries/read_dump.lib.php on line 91 o que significa isso.. não estou entendendo. basicamente só falta isso funcionar para liberar o acesso à intranet. valeu. muito.

17 January 2007

instalando e substituindo diretórios

retiro o que eu disse. está rodando sim.. sem o pv.exe. acho que solucionei.. vou manter em quarentena. e outra coisa.. para variar.. do nada.. no meu pc passou a rodar tb.. acho que no erro da importação, acabou no fundo atualizando sim. blz.. agora irei supervisionar o servidor. obrigado a todos pela ajuda e pela força. por enquanto está meio que solucionado o problema. em relação à migração, acredito que seja aquilo mesmo. copiar todo o conteúdo, alterar mainfile.php, conf do apache se for preciso e linhas no backup do banco de dados. abraços a todos. qualquer problema contacto vocês.rs. obrigado de novo.

instalando e substituindo diretórios

voltou a sobrecarregar. estou ficando desanimado disso tudo. está realmente me cansando. :-( e agora, o que será? estou tentando instalar o xoops na minha máquina mas no final da configuração, diz que não está sendo possível, acessar o banco de dados. está brabo o negócio aqui. ----- ainda não consegui restaurar o banco com o último arquivo enviado para que eu tentasse de novo. fatal error: maximum execution time of 300 seconds exceeded in c:\server\phpmyadmin\libraries\read_dump.lib.php on line 91 estão acabando as energias e as soluções. :cry: :cry: :cry:

instalando e substituindo diretórios

talvez não precise mais fazer a migração para a minha máquina. acho que descobri o que estava sobrecarregando o servidor. um aplicativo do apache, chamado pv.exe. fiz uma consulta dos processos quando o servidor estava bom e quando estava sobrecarregado. a diferença era justamente o pv.exe. com isso, consultei na net e descobri que ele afeta o apache. dei um stop no apache e alterei o pv.exe . startei de novo o apache e por enquanto está tudo certo. mas ainda estou em teste.. se o servidor ficar o dia todo legal.. será isso mesmo. estou torcendo para que seja !.rs. valeu. abraços

16 January 2007

instalando e substituindo diretórios

ainda não recebi seu email. quando atualizo o xampp, ele atualiza automaticamente a versão do php? como faço para atualizar.. instalar do 0? valeu

instalando e substituindo diretórios

pra ver esse problema de tempo de execução, abri o phpmyadmin aqui para incluir esse banco de dados nele. selecionei um banco de teste e dentro do banco de teste fui na opção de importar. não deu esse problema de tempo excedido, mas deu outro: ele não aceitou importar. então eu fui no arquivo .sql, tirei as primeiras linhas dele e compactei de novo em .gz. então foi. parece que as linhas que informavam a versão do phpmyadmin tavam bloqueando a importação. vou mandar a versão atualizada para o seu email. pra atualizar o phpmyadmin você tem que atualizar o xampp. já tem uma versão 1.5.5 do xampp. -------------------- como faço para atualizar meu xoops 2.0.13 para 2.0.16? o que tenho exatamente que fazer ? é fácil? isso atualizará também o phpmyadmin ? o xoops é totalmente independente de outros programas, então não muda nada no phpmyadmin. pra atualizar para o 2.0.16, dá

instalando e substituindo diretórios

tudo bem.. vou tentar. obrigado. uma dúvida, tem como atualizar somente o phpmyadmin? valeu. . tempo depois. fatal error: maximum execution time of 300 seconds exceeded in c:\server\xampp\phpmyadmin\libraries\read_dump.lib.php on line 91 -------------------- como faço para atualizar meu xoops 2.0.13 para 2.0.16? o que tenho exatamente que fazer ? é fácil? isso atualizará também o phpmyadmin? valeu

instalando e substituindo diretórios

mesmo trocando os ips, não muda nada. o problema está mesmo no banco de dados. só que no meu phpmyadmin, está dando erro fatal por causa do tempo que está levando para restaurar. vou tentar fazer o seguinte.. estarei disponibilizando um arquivo zipado com o banco de dados e o arquivo .txt , já alterado para ser restaurado. se alguém conseguir fazer isso, pode me mandar esse diretório "ibf" de volta pelo email romulofloriano@gmail.com endereço do arquivo: http://ibf.com.br/bd.zip muito agradecido

instalando e substituindo diretórios

deu erro na restauração do banco. fatal error: maximum execution time of 300 seconds exceeded in c:\server\xampp\phpmyadmin\libraries\read_dump.lib.php on line 91 já consegui colocar todos os arquivos. no diretório da minha máquina.. acho que agora só falta acertar o problema do banco (direcionamentos). em último caso, mudar o ip da minha máquina com o do servidor. sinto que estamos chegando lá.rs. valeu

instalando e substituindo diretórios

abri o backup do banco e estava realmente referenciando a outro endereço. estava tudo como http://10.1.1.18 troquei para http://localhost. os arquivos que estão faltando é geral, não só da pasta template. vou terminar de copiar, se der para copiar. e tentar restaurar esse backup com os endereços trocados. vou tentar jogar por cima e executar. se não der certo farei o que você falou para fazer. agora é cruzar os dedos e torcer.rs. valeu

instalando e substituindo diretórios

rômulo, fiz isso, na verdade até já tinha feito antes.. mas não muda.. a página continua abrindo em branco.alterei mas na verdade o caso é ao contrário.. mas mesmo alterando não acessa nada.. tem que ficar só localhost mesmo. aí abre a maldita página em branco. cheguei hoje a trocar o ip da máquina, achando que o portal estava associando o ip do servidor.. mas não funcionou. o que eu não consigo entender é que: copie tudo do servidor para o mesmo endereço (diretório) na minha máquina. executei o controle do xampp para acionar o apache e o mysql. e quando abre, fica tudo branco. porque no servidor abre normalmente e aqui não ? a coisa não está andando, por isso recomendo voltarmos a estaca zero e começar de novo. você conseguir fazer um backup do banco de dados mysql se conseguiu, faça na o seguinte (na máquina que você quer que fique

instalando e substituindo diretórios

descobri outra coisa. fiz uma pesquisa nos diretórios e constatei uma diferença enorme. no servidor, tem 42.284 arquivos. na minha máquina tem 41.306 vou ter que copiar de outra forma.

instalando e substituindo diretórios

citando..: por volta da linha 34, você vai encontrar: define('xoops_root_path', 'c:/servidor/htdocs/'); altere para: define('xoops_root_path', 'c:/servidor/xampp/htdocs/'); fiz isso, na verdade até já tinha feito antes.. mas não muda.. a página continua abrindo em branco. citando.: --> se no servidor anterior, o portal estava em um pasta dentro do localhost (htdocs) e agora esta na raiz do localhost (htdocs), você precisará alterar outra linha: define('xoops_url', 'http://localhost/xoops/20132'); para. define('xoops_url', 'http://localhost/'); alterei mas na verdade o caso é ao contrário.. mas mesmo alterando não acessa nada.. tem que ficar só localhost mesmo. aí abre a maldita página em branco. cheguei hoje a trocar o ip da máquina, achando que o portal estava associando o ip do servidor.. mas não funcionou. o que eu não consigo entender é que: <b

15 January 2007

instalando e substituindo diretórios

é essa opção mesmo que tem no meu phpmyadmin. vou tentar utilizar isso amanhã pela manhã. quanto à hierarquia. no servidor está c:\server. na minha máquina pode ficar qualquer coisa, contanto que funcione. por enquanto a única coisa que está acontecendo é abrir o portal tudo em branco. aí se eu digitar http://localhost/admin.php.. abre a tela dizendo que não tenho acesso aquela area e volta para a tela em branco. é como se já estivesse tudo certo.. mas com algo bloqueando o acesso à página principal, ou algo errado .. não sei o que.. não modifiquei nada em códigos antes disso acontecer. valeu.. até amanhã

instalando e substituindo diretórios

rômulo, se não der certo, tenta uma "gambiarra" ai. na pasta do servidor anterior, ache o pasta do banco de dados do mysql. suspeito que esteja em: c:\servidor\mysql\data\ibf. então copie a pasta ibf para o mesmo local no xampp, que provavelmente é: c:\servidor\xampp\mysql\data\ ficando, obviamente, "c:\servidor\xampp\mysql\data\ibf" copie todos os arquivos do portal que estavam no servidor anterior, sem exceção, na forma que estavam. para a pasta htdocs do xampp. (pelo que entendi, o portal estava na raiz do localhost, certo?) ou seja, para a pasta. c:\servidor\xampp\htdocs\ detalhe importante: acesse o banco de dados pelo phpmyadmin (do xampp) e garanta que o usuário e a senha ao mysql sejam o mesmo do mysql do servidor anterior. detalhe importante 2: abra o arquivo mainfile.php. por volta da linha 34,

instalando e substituindo diretórios

dependendo da versão do phpmyadmin, a forma de se chegar ao ponto de exportar ou importar é diferente, lembro que depois de uma atualização do lampp as opções mudaram um pouco de lugar. no caso de importar, vê se essa sua versão tem a aba sql, ali deve ter a opção de importar um arquivo .sql. ou em vez de "importar" a opção pode estar como "executar" para executar um arquivo .sql. mas uma coisa não ficou muito clara: como exatamente você quer deixar a hierarquia do portal? você quer colocar dentro de uma pasta ou direto no diretório do xampp? é melhor você colocar numa pasta particular, tipo c:\server\site assim fica mais fácil organizar. o mesmo vale para o que está no serv. original: está diretamente dentro do htdocs ou está tipo htdocs/site? se tiver htdocs/site/ você joga a pasta portal para c:\server\, se tiver direto, você joga tudo o que for do xoops que está dentro do htdocs para o c:\server\site. de qualquer maneira, o htdcos em si não vai para

instalando e substituindo diretórios

fiz o seguinte.. na raiza de c:\server, tem o conteúdo copiado do servidor, na mesma raiza, tem o diretório xampp (uma nova instalação local). estou tentando fazer a importação e a substituição dos arquivos xoops do htdocs. às 17:50 terei que parar.. só voltando amanhã às 08:30 não desistirei. obrigado pela ajuda de todos. bem, ainda tenho uns 30 minutos.rs. como faço para atualizar o phpmyadmin? o que apareceu para mim foi. uma tela com isso : fazer consulta sql no banco de dados ibf: mostrar esta consulta sql de novo. ou localização do arquivo texto: (tamanho máximo: 16,384kb) compressão: auto-detectar nenhum "compactado com gzip" conjunto de caracteres do arquivo armscii8 ascii big5 binary cp1250 cp1251 cp1256 cp1257 cp850 cp852 cp866 cp932 dec8 eucjpms euckr gb2312 gbk geostd8 greek hebrew hp8 keybcs2 koi8r koi8u latin1 latin2 latin5 latin7 macce macro

instalando e substituindo diretórios

rômulo, estou usando o phpmyadmin 2.8.2.4 e nesse tem a abinha "exportar" e outra abinha "importar". pelo jeito, o phpmyadmin 2.6 não tem. então tenta ir na abinha "sql". lá pode ter um campo onde você busca o arquivo com os dados sql para serem executados. acho que é isso. [editado] com o tamanho do tópico, fiquei confuso do ponto em que você está. como está essa tranferência?

instalando e substituindo diretórios

citando: - entrar no phpmyadmin do seu pc e selecionar importar banco. não estou achando esta opção. somente exportar. como não achei a opcao importar.. colei em cima o banco do servidor, (teste provisorio), com isso quando entrei no localhost, recebi esta tela. module file for articles not found!module file for catads not found!module file for extcal not found!module file for pical not found!module file for rmdp not found!module file for amevents not found!module file for xhnewbb not found!module file for myalbum not found!module file for sitemap not found!module file for smartsection not found!module file for wfsection not found! terei agora que colar o conteúdo da pasta htdocs do servidor ?

instalando e substituindo diretórios

edit 2: veja se estou certo na ordem das tarefas. 1) instalei o xampp (c:\server\xampp) versão 1.5.0 2) descompactei a pasta xoops 2.1.13 no lugar da htdocs. 3) começarei a instalar normalmente e dar o nome do banco de "ibf" o mesmo do servidor. 4) depois restaurarei o banco ibf antigo. 5) copiarei o diretório htdocs do servidor para a minha máquina (substituindo o novo). estou certo. ? você não precisa fazer todas essas etapas. pode pular a instalação de um novo xoops (passo 3), assim pula a etapa 2 também, porque não precisa jogar uma versão do xoops que não seja a versão usada no serv., já que você vai jogar depois os arquivos do serv. portanto, é só fazer o passo 4 e 5 depois do 1. não precisa copiar o htdocs, apenas os arquivos xoops que estão no htdocs. no fim, entra pela url http://localhost/site

instalando e substituindo diretórios

blz. consegui salvar. veja se estou certo na ordem das tarefas. 1) instalei o xampp (c:\server\xampp) versão 1.5.0 2) descompactei a pasta xoops 2.1.13 no lugar da htdocs. 3) começarei a instalar normalmente e dar o nome do banco de "ibf" o mesmo do servidor. 4) depois restaurarei o banco ibf antigo. 5) copiarei o diretório htdocs do servidor para a minha máquina (substituindo o novo). estou certo. ?

instalando e substituindo diretórios

porque quando somente faço a cópia de um diretório para outro (c:\server\ para c:\server\) e tento abrir localhost, recebo esta tela: this page cannot be displayed due estou an internal error. if you are the administrator of this site, please visit the xoops troubleshooting page for assistance. error [xoops]: unable estou connect estou database in file c:\server\htdocs\class\database\databasefactory.php line 34 não posso utilizar sem instalar? fiz o backup do banco como você falou. acho que vou tentar instalar tudo normalmente e restaurar. o problema é que quando eu instalar, ele criará um diretório com nome diferente (c:\server\xampp\ em vez de c:\server )e terei que mudar algo. e lá vamos nós.rs. valeu

instalando e substituindo diretórios

o portal no servidor está funcionando, o problema é que quando starto os serviços, o processador chega a 100%, aí trava tudo.. ninguem acessa mais nada.. nem eu. por isso estou precisando colocar tudo na minha máquina, a qual será provisoriamente o servidor da intranet. depois montaremos uma máquina com linux para colocá-la. módulos instalados: articles, emeventos, xh-forum, wsproject, smartsection, sitemap, anunces, pical, extcal, myalbum-p, votacoes, links, wfsections, entre outros. vou tentar fazer o esquema de restaurar o backup. uma pergunta: no servidor, o portal está no diretório. c:\server\ na minha máquina, o xampp está criando: c:\server\xampp. com essa mudança, o que realmente terei que mudar ? os que sei são ( theme.html e maifile.php ), algum outro mais ou alguma outra configuração? ---- citando: quanto ao negócio de intranet. qual é a banda dos equipamentos, 10/10

instalando e substituindo diretórios

consegui acessar a adm do portal, mas a opção de bloquear ips estava desmarcada. as opções estão acabando. estou ficando perdido, sem saber o que fazer. está tudo muito estranho.

instalando e substituindo diretórios

rômulo, - qual o servidor você usava antes do xampp 1.5.0? - é possível restaurar o portal no servidor anterior? se for possível, é recomendável que você volte ao status anterior e siga algum dos dois tutoriais acima, que não tem erro. -- parece que você ainda não está entendendo como se faz um backup do banco de dados. se não estiver fala que é super fácil e já revelamos aqui. se não for mais possível restaurar o servidor anterior, aí partimos para uma "gambiarra" para ver se funciona! é isso. [editado] quais módulos você usa nesse site.? quanto ao negócio de intranet. qual é a banda dos equipamentos, 10/100mb? usam switchs ou hubs? quantos utilizadores há na rede? qual a banda da conexão de internet?

bacon's TAGS related to tag diretórios

apache +   brasil +   brazilian +   comparação +   cube +   fbs +   forum +   instalando +   internet +   mysql +   php +   portuguese +   renomeados +   renomear +   servidor +   substituindo +   todos +   tradução +   windows +   XAMPP +   xoops +