public marks

PUBLIC MARKS from bacon with tag atualizei

April 2007

atualizei o core e o bloco menu perdeu definição

fbs777, sua dica funcionou corretamente, obrigado! menos um problema, ainda faltam 369.658.124.362. animo pessoal!

atualizei o core e o bloco menu perdeu definição

repare que entre os dois arquivos que você colocou existe diferenças em relação à nomes de classes/id que são buscadas no css do tema. você pode escolher onde alterar os nomes: no template do xoops mexico ou no css do tema. um tem que se adaptar ao outro, você escolhe qual. exemplo: no xoops normal, cada item leva a classe. class="menumain" enquanto que no xoops mexico os mesmos itens levam a classe. class="mainmenu" então para adaptar a formatação desses itens, vá no css do tema e procure a linha. .menumain. e troque por. .mainmenu. ou crie uma nova classe .mainmenu apenas copiando o conteúdo ( o que vai dentro do {} ) da classe .menumain. pra facilitar, você pode abrir o css do tema padrão do xoops mexico e copiar as novas classes que são carregadas no template do bloco, aí cola as novas classes no css do tema que você usa

atualizei o core e o bloco menu perdeu definição

vou começar a analisar agora, que tenho as informações, mas quem puder me ajudar, eu agradeço imensamente. arquivo do xoops 2.0.16 comum: <table cellspacing="0"> <tr> <td id="mainmenu"> <a class="menutop" href="<{$xoops_url}>/"><{$block.lang_home}></a> <!-- start module menu loop --> <{foreach item=module from=$block.modules}> <a class="menumain" href="<{$xoops_url}>/modules/<{$module.directory}>/"><{$module.name}></a> <{foreach item=sublink from=$module.sublinks}> <a class="menusub" href="<{$sublink.url}>"><{$sublink.name}></a> <{/foreach}> <{/foreach}> <!-- end module menu loop --> </td> </tr> </table> arquivo do xoops 2.0.16 méxico: <div class="mainmenu"> <a class="menutop" href="<{$xoops_url}>/"><{$block.lang_home}></a> <!-- start module menu loop --> <{foreach item=modu

atualizei o core e o bloco menu perdeu definição

siga o que o fábio falou, mas tenha em mente que a versão xoops 2.0.16 by exm usa um novo conjunto de estilos de letras que modifica a formatação natural. se não me engano existe alguma coisa aqui no fórum explicando isto. :-) :)

atualizei o core e o bloco menu perdeu definição

compare o arquivo. ../modules/system/templates/blocks/system_block_mainmenu.html. do xoops "normal" com o mesmo arquivo do xoops mexico. se quiser mudar alguma coisa, depois de salvar atualize o system.

atualizei o core e o bloco menu perdeu definição

atualizei meu portal de 2.0.13 para 2.0.15, e depois para 2.0.16, e até o momento, nada de errado, mas quando atualizei para 2.0.16, versão do méxico, o bloco de menu principal simplesmente perdeu a formatação do módulo. interessante que os menus criados a partir do multimenu ainda estão formatados corretamente. utilizo o lucas02 azul (bem parecido com o antigo do xoops). alguma luz?

August 2006

atualizei do 13 para o 14 e estou com problemas

bem. já sei que o problema não deve estar no javascript desses blocos especificamente. instalei um xoops 14 novinho e o problema não existe. então meus problemas devem ser gerados por algum(ns) módulo(s) que estou usando. na verdade esse é o portal em que mais tenho módulos em uso e já estou percebendo erros em vários. habilitei o "mostrar erros do php" e encontro muitos erros. em alguns módulos. só que realmente nem sei por onde começar porque não sei como arrumar isso. sei que eu teria que me preocupar por um módulo por vez. mas não entendo de php. algumas coisas consigo resolver por "tentativa e erro". mas realmente, nestes casos, estou totalmente desencorajada a tentar. alguém topa me ajudar nesta empreitada? creio que teríamos a solução para futuros problemas que muitos terão assim que migrarem para o 14 como fiz. aguardo. débora

atualizei do 13 para o 14 e estou com problemas

débora. no meu caso > ainda não testei o 214 :-( mas diga, esse problema ocorre tanto no ie qto no ff? qual é o erro específico de javascript que aparece para você? a função que abre os popups é essa aí embaixo.openwithselfmain. <div class="xoopscode"><pre><samp><code>javascript:openwithselfmain('http://www.xoopscube.com.br/misc.php?action=showpopups&type=online','online',420,350);</code></samp></pre> será que ela foi alterada no 214? desculpe a falta de informações mais detalhadas débora :-( mas poste aqui algo mais prá gente :-)

atualizei do 13 para o 14 e estou com problemas

atualizei dois portais da versão 2.0.13.2 para a 2.0.14 e agora estou com problemas com janelas pop-ups. explicando melhor. uso o bloco "sobre o portal" que dá a opção de "recomendar o portal". agora, ao se clicar nesse link, dá erro de javascript. o mesmo acontece com o bloco "utilizadores on-line". não posso mais clicar em "mais" e saber por onde andam os que estão on-line. alguém já teve esse problema? alguém sabe como resolver? aguardo. débora

bacon's TAGS related to tag atualizei

bloco +   core +   dahora +   debora +   definição +   estou +   fbs +   forum +   menu +   perdeu +   problemas +   ramos +   templates +   wilson +   wilsoncortez +   xoops +