public marks

PUBLIC MARKS from bacon with tags mais & campos

August 2007

formulaire 3.24 não deixa mais criar campos obrigatórios

então, pessoal, consegui resolver o problema, substituindo os arquivos "form.php" e "formselect.php", da pasta "/class/xoopsform/" do xoops, por arquivos de uma versão mais antiga, creio eu que a 2.0.13. quem quiser, posso enviar por e-mail, é só me passar o e-mail.

formulaire 3.24 não deixa mais criar campos obrigatórios

por favor, se a solução é mesmo a troca desses arquivos da versão 2.0.13. peço que alguém os envie para mim porque eu não tenho essa versão. agradeço antecipadamente. débora

July 2007

formulaire 3.24 não deixa mais criar campos obrigatórios

tenho um xoops 2.0.15 com formulaire 3.3 e o mesmo problema. na verdade o módulo permite a criação dos campos obrigatórios. só eles não ficam como obrigatórios já que aceita o envio do formulário sem o preenchimento desses campos. abraços. débora

May 2007

formulaire 3.24 não deixa mais criar campos obrigatórios

olá,! então, gisa_iagami, como eu disse acima, instalei essa nova versão do formulaire que o philou me enviou (3.3.1), em um portal para testes, e fiz alguns testes com a mesma. bom, o problema continua. criei um formulário, definindo alguns campos como obrigatórios, e eles não são requeridos no momento do preenchimento, podendo o formulário ser submetido sem o preenchimento deles. até respondi ao philou informando da continuidade do problema, vamos ver o que ele diz. enviei a ele também os dois arquivos que "resolveram" o problema, ambos do xoops 2.0.13, o "form.php" e o "formselect.php". acredito que realmente o problema esteja aí, mas vamos ver. :-) um grande abraço!

formulaire 3.24 não deixa mais criar campos obrigatórios

gisa_iagami! então, antes de efetuar as modificações acima, eu havia entrado em contato diretamente com o philou, o desenvolvedor do formulaire, informando ao mesmo o problema, e perguntando se ele teria alguma dica a respeito do bug. ele acaba de me responder o e-mail, e enviou anexado ao mesmo uma nova versão do formulaire, a 3.3.1, dizendo que com esta não ocorreria o problema. bom, parece que o problema é relacionado às modificações feitas nos arquivos "formselect.php" e "form.php", não é? de qualquer forma, vou instalar essa versão que o philou me enviou, e efetuar alguns testes, postando aqui em seguida o resultado.

formulaire 3.24 não deixa mais criar campos obrigatórios

opa marcos, desculpe a demora. well, se entendi corretamente, deverá dar pau então na versão do xoops 2.0.16 oficial também. só quero lembrar aos demais que esta novidade que foi introduzida na versão 2.0.15 by xoops foi aprovada por skalpa e está fazendo parte da versão oficial do xoops 2.0.16. os créditos foram nomeados de forma diferente, mas a consistência nos forms é a mesma. agora não sabia deste efeito colateral, o que tenho certeza é que na versão 2.0.16 by exm está funcionando corretamente as permissões. com certeza a sua dica irá ajudar alguns utilizadores, mas queria ver alguém que está usando a versão 2.0.16 xoops.org e 2.0.16 by exm para ver se o problema também acontece. []s

formulaire 3.24 não deixa mais criar campos obrigatórios

pessoal, beleza? então, consegui resolver o problema, e acredito que este não esteja no formulaire, mas sim, na versão do xoops que estou utilizando no portal em questão, que é a "2.0.15 by xoops/xoopers". andei dando uma olhada em alguns arquivos da mesma, e encontrei em alguns algumas seções com "hacks" inseridos pela equipe do xoopers 2.0.15, hacks estes relacionados sempre à questão dos formulários, no xoops. bom, o que fiz não foi nada muito técnico, mas deu certo. rsrs :-) simplesmente substituí os arquivos "formselect.php" e "form.php" da pasta /class/xoopsform da minha versão "2.0.15 by xoops/xoopers" pelas versões dos mesmos existentes na versão 2.0.13 do xoops, e agora os campos obrigatórios estão funcionando perfeitamente. espero que esta dica ajude mais alguém. :-)

formulaire 3.24 não deixa mais criar campos obrigatórios

gisa_iagami! tudo bem? deixa eu perguntar uma coisa: você conseguiu dar uma olhadinha nesse problema? já fucei em tudo quanto é coisa, mas não descobri porque ele não "obriga" mais o usuário a preencher os campos obrigatórios. e, além disso, notei alguns problemas estranhos nessa última versão do formulaire. a função de "duplicar" forms está duplicando formulários que não mandei duplicar. ou seja, mando clonar o formulário x, e ele clona o y.rsrs

March 2007

formulaire 3.24 não deixa mais criar campos obrigatórios

oi marcos, eu acho que tinha marcado para dar uma olhada nisto aí mas esqueci. eu vou testar logo mais para ver se vejo o problema. se alguém puder ajudar também, não passe vontade, colabore ai.

formulaire 3.24 não deixa mais criar campos obrigatórios

amigos! alguém teria alguma ideia a respeito do problema acima? agradeço desde já por qualquer ajuda.

formulaire 3.24 não deixa mais criar campos obrigatórios

gisa_iagami! então, baixei e instalei do zero a versão 3.3, mas o problema continua. os campos estão configurados para serem obrigatórios, e aparece o * ao lado. mas ele passa batido, mesmo que eles estejam no final, ou no meio, ou no início. será que tem alguma forma de mexer nisso?

formulaire 3.24 não deixa mais criar campos obrigatórios

marcos, eu testei a versão 3.30 e até ajudei a traduzir o help. fiz testes o tempo todo com a versão 2.0.15 by xoops exatamente igual a você. eu percebi que o campo é mostrado com o * direitinho e realmente está passando quando o campo está no meio, mas se está no início ou final parece que trava. veja aí se é isto mesmo. se puder, use a versão 3.3, mas não aconselho atualização, deveria instalar do zero mesmo. ela está a disposição no http://www.xoopscube.com.br em revisão.

formulaire 3.24 não deixa mais criar campos obrigatórios

pessoal! gostaria de saber se alguém aqui já passou por isso: instalei o formulaire em um novo portal, e ele não deixa mais criar campos obrigatórios. quer dizer, deixar ele deixa, mas quando se preenche o formulário, mesmo que não se preencha campos obrigatórios, ele permite o envio. meu xoops é o 2.0.15 (by xoopers), e o formulaire é o 3.24. agradeço por qualquer ajuda. abraços!

bacon's TAGS related to tag mais

acabei +   Administração +   album +   alguém +   alternativa +   anime +   apache +   area +   artsgeral +   BARATOS +   bloco +   blocos +   blogs +   brasil +   campos +   catads +   cesarfelip +   como +   comparação +   consigo +   criar +   darlanseconello +   debora +   deixa +   destaque +   domínios +   doramas +   download +   Duarte +   duartejn +   duvidas +   eguide +   email +   entra +   enviar +   envio +   especial +   estavel +   faz +   fbs +   formulaire +   forum +   foto +   free +   frodobr +   house +   incluir +   jmusic +   jnation +   joelaleixo +   lab +   leuonline +   libera +   liberar +   Marcos +   menu +   mesma +   módulos +   mostra +   Mr +   muito +   multi +   mysql +   notícia +   nova +   novo +   obrigatórios +   pacote +   pag +   pesquisa +   portal +   postnuke +   publisher +   qual +   ramos +   release +   rápido +   Ronaldo +   se +   seconello +   servidor +   smarty +   sobre +   software +   spotlight +   tem +   temas +   templates +   themes +   trabalho +   tradução +   uma +   usados +   versao +   vez +   windows +   xcgal +   xoops +   xoopspoll +   zy +