public marks

PUBLIC MARKS from bacon with tags módulos & blocos

2007

aparência de módulos, blocos e grupos

já está resolvido. obrigado e desculpa pela demora na resposta, porque estava de férias em palmas/to e quiando retornei tive um problema com a conexão de internet.

aparência de módulos, blocos e grupos

fiz conforme o luix orientou e o resultado me surpreendeu. no debug do php: all errors (10) queries (15) blocks (0) extra (0) timers (3) errors. notice: only variables should be assigned by reference in file /modules/system/admin/preferences/main.php line 78 notice: only variables should be assigned by reference in file /class/xoopslists.php line 200 notice: only variables should be assigned by reference in file /kernel/module.php line 542 notice: only variables should be assigned by reference in file /modules/system/admin/preferences/main.php line 155 notice: only variables should be assigned by reference in file /kernel/tplset.php line 193 notice: only variables should be assigned by reference in file /modules/system/admin/preferences/main.php line 136 notice: only variables should be assigned by reference in file /modules/system/admin/preferences/main.php line 94 notice: only variables should be assigned

aparência de módulos, blocos e grupos

olá radames, para ativar o debug vá em: admistração >> sistema >> preferências >> configurações gerais mais ou menos no meio da página você encontrará o item ligar o modo de teste (debug)? as opções [u]mostrar erros do php, do mysql/blocos ou do smarty[/u] estão numa drop list. após a ativação do debug, se houver algum erro ele será exibido ao final da página após o rodapé. é isso

aparência de módulos, blocos e grupos

o que é ativar "debug" do php, do mysql edo smarty, e como faço para ativar? primeiramente estarei tentando a dica dos módulos, inclusive aproveito para dizer que tem um módulo que não uso já a algum tempo e mesmo ele estando desisntalado não consigo excluí-lo do server. já renomeei e nada. existe alguns arquivos dentro que não aceitam ficar como "chmod 777". poderia ser isto? e quanto a atualizar para o xoops 2.0.16, resolveria?

aparência de módulos, blocos e grupos

antes tente ativar cada debug e ir vendo os erros e reporte aqui. muito provavelmente tem um módulo que está dando o conflito e impedindo os demais. as poucas vezes que eu tive esse tipo de problemas, sempre tinham algum arquivo corrompido no módulo. uma dica para descobrir qual é o módulo: geralmente eles aparecem na lista na ordem em que foram upados. então, identificando o último módulo que aparece na lista é só ir ao módulo que foi upado após ele. ai, para ter certeza que é o danado, apague ele e entre de novo na lista, se ela aparecer completa, ou seja, mostrar o footer, era mesmo o danado. aí é só conferir. é isso

aparência de módulos, blocos e grupos

antes tente ativar cada debug e ir vendo os erros e reporte aqui. muito provavelmente tem um módulo que está dando o conflito e impedindo os demais. - 1o. debug do php. - 2o. debug do mysql. - 3o. debug do smarty, porém, acho que não seria este. se for usando o tema default e já tendo atualizado o system, se prepara que provavelmente será aquele problema com alguma tabela danificada no seu mysql e se for mesmo as tpls, sai debaixo que vem problemas para você infelizmentevamos torcer para não ser isto. observação: eu não vou questionar se houve alteração no seu server, mas se houve tu precisaria saber. muitos problemas podem estar relacionados a isto também e assim iremos todos ficar vendidos. pensamento positivo meu brother em cristo.

aparência de módulos, blocos e grupos

cara gisa_iagami, obrigado pelas dicas, fiz conforme você instruiu, mas não deu certo. alterei o tema para defalt, atualizei o system e nada. depois deletei o arquivo "adminmenu.php", fiz novo acesso a administração, atualizei de novo o system, e mais uma vez nada! não apareceu os módulos, inclusive o módulo parceiros ocorreu de as imagens com os logotipos desaparecer de repente, então quando desinstalei o módulo não consegui mais visualizá-lo mesmo ele estando na pasta "modules". agora acho que terei que seguir sua doca de atualização do system. como faço esta operação? vou ter que encarar esta parada! att. paulo radamés

aparência de módulos, blocos e grupos

ok paulo, acho que agora começo a entender o que pode estar ocorrendo. existe o diretório cache no raiz do seu xoops. ele deve conter um arquivo de index com redirecionamento e um arquivo chamado adminmenu.php por padrão este diretório deve estar marcado também com chmod 777 para que possa ser alterado quando alguma coisa ocorrer nas configurações da administração e permitir a geração de alguns templates que serão armazenados no diretório templates_c experimente verificar via ftp as permissões do seu diretório cache não importa se acha que está certo ou não, verifique e apague este arquivo adminmenu.php. tu deverá fazer o login de novo no portal normalmente com um usuário com poderes administrativos. vai tentar o acesso na área de administração. deverá ser feito uma pergunta lhe informando que é a primeira vez que tu está acessando esta área. neste momento o system (módulo xoops), i

aparência de módulos, blocos e grupos

caro luís, obrigado pela dica, instalei o "blocksadmin", agora gostaria de saber se existe um módulo que tenha a mesma função que este, só que em relação aos módulos do portal, porque não consigo mostrar todos os módulos disponíveis para instalação. quanto a dica de privilégios de administrador, eu já conhecia este procedimento, porém, o sistema não me fornece o nome dos visitantes cadastrados para que eu possa autorizar como administrador. também o bloco de "novos utilizadores" não aparece, mesmo constando no "blocksadmin" como visível. já giz a atualização do módulo "sistema" e continua na mesma. att. paulo radamés

aparência de módulos, blocos e grupos

olá radames, - para trabalhar com os blocos, sempre uso o módulo blocksadmin é muito fácil de utilizar e ainda permite trabalhar com as permissões dos grupos. - para adicionar algum usuário aos privilégios de administrador, vá em administração >> sistema >> grupos selecione o grupo administradores, e bem ao final da página terá uma listinha dos utilizadores, selecione ele e adicione no grupo. (ah, ha algum tempo vi algo, sobre o limite de usuário naquele listinha. mas não me lembro). é isso

aparência de módulos, blocos e grupos

pessoal, após entrar na página de administração do portal não estou conseguindo mostrar alguns "módulos" instalados e nos "blocos" também está acontecendo o mesmo problema, porque existe um bloco que criei, porém só consigo mostrar quando entro na páfina principal de "grupos", no "blocos" ele não consta. aproveitando não estou conseguindo autorizar que um determinado "usuário" venha ter os mesmos privilégios do administrador. parece que a opção sumiu. att. paulo radamés

2003

módulos sem os blocos da esquerda

fica feio... alguém sabe algum jeito para eu fazer a coluna da esquerda sumir, mas sem deixar o layout deformado ? putz, fica mesmo... bem, ainda não testei, mas dê uma olhada neste código: <div class="xoopscode"><pre><samp><code> <table> <tr> <td width="20%"> <!-- start left blocks loop --> <{foreach item=block from=$xoops_lblocks}>  <{$block.title}> <{$block.content}> <{/foreach}> <!-- end left blocks loop --> </td> <td align="center"> <!-- display center blocks if any --></code></samp></pre> o "loop", a repetição dos blocos da esquerda, fica dentro de uma coluna que é iniciada antes dos blocos e tem o tamanho de 20% (independentemente do tamanho dos blocos)... é provável que o seu problema acabe se ajustar esse tamanho para 0%, por exemplo. e se isso causar algum problema quando o bloco os blocos ficarem visíveis, basta inserir uma

módulos sem os blocos da esquerda

olha so como fica o forum se eu "desligo" as colunas da esquerda: [url=http://furry.com.br/temp/grrrr!.jpg][img]http://uivo.kit.net/grrrr!_.jpg[/img][/url] fica feio. alguém sabe algum jeito para eu fazer a coluna da esquerda sumir, mas sem deixar o layout deformado? :( o portal está 80% pronto, so falta isso para eu migrar para o xoops, ainda não tenho certeza se vou usar o phpbb ou o newbb... ambos parecem otimos. usaria o phpbb se o esquema fosse aquele de deixar o phpbb "fora do layout" (como expliquei no meu outro topico)

módulos sem os blocos da esquerda

sim. se eu entendi direito você pode configurar na configuração de blocos para eles sejam exibidos somente em determinadas páginas. vá em administração --> blocos e clique em editar no módulo que você deseja. depois é só você selecionar aonde você quer que o(s) bloco(s) apareça. é isso que você queria? exatamente isso eyekeeper! so que eu estou tendo problemas assim mesmo. com ou sem os blocos laterais, o espaço reservado aos mesmos ainda aparece, so que fica em branco. em alguns temas do *nuke isso também acontecia, em outros não. estou especulando que talvez seja algo parecido o que está acontecendo no xoops. porém eu estou com dúvidas por que em todos os temas está acontecendo a mesma coisa.

módulos sem os blocos da esquerda

o que pode ser também é que em algum lugar algum bloco da esquerda possa estar habilitado

módulos sem os blocos da esquerda

embora tenha feito tudo que sugeriram aqui comigo não deu certo que problema estranho... nunca vih isso não funcionar. pode dizer como você fez? será que não foi o cache que atrapahou a atualização para nova confiuguracao? :-/ soh para conferir: 1) ...logue no seu portal e entre na pagina: "seusite.com/modules/system/admin.php?fct=blocksadmin" 2) escolha o primeiro bloco que você deseja configurar, e clique no endereço "editar". aparecerao as opcoes: nome: (nome do bloco) tipo de bloco (se é esquerdo, central, direito, etc) posição: (equivalente ao "peso" dos nukes) visível: (sim ou não) visível em: (aqui é onde você configura em quais paginas ele aparecerah) título: (bla, o titulo do bloco...) conteúdo: (editação do modelo) tempo de vida do cache: como você configurou essas opcoes no seu site?

módulos sem os blocos da esquerda

no meu caso eu editei os meus modelos, e ficou melhor fixos em pixels mesmo, agora mesmo assim continuo com problemas de layout em 800 por 600 principalmente no módulo fórum que realmente ficaria mil vezes melhor sem a coluna esquerda, mas embora tenha feito tudo que sugeriram aqui comigo não deu certo :(

módulos sem os blocos da esquerda

outra ideia também é você editar os modelos e fazer com que os blocos tenham tamanho fixo em pixels e não por percentuais, aí você poderá definir exatamente o tamanho dos blocos e não dependerá de resolução. lembre que daí você ainda não terá o ajuste automático de tamanho dos blocos para cada resolução diferente. :-)

módulos sem os blocos da esquerda

para fazer isto com o fórum é fácil, o problema são os outros módulos. tome muito cuidado com blocos que sejam aplicados a todas as páginas. se definir um módulo para o lado direito em todas as páginas, vai afetar o fórum e aí não vai funcionar. posso estar errado, mas testei isto com um tema padrão e somente liberando o acesso especialmente para os blocos consegui este efeito. o problema é que para alguns módulos eu precisa e em outros não, aí a casa caiu e não consegui conciliar do jeito que queria, aí deixei assim mesmo, usando , esquerdo,meio e direito. mas se alguém tiver alguma ideia ou se você conseguir resolver, avise a turma aqui está?

módulos sem os blocos da esquerda

sim. se eu entendi direito você pode configurar na configuração de blocos para eles sejam exibidos somente em determinadas páginas. vá em administração --> blocos e clique em editar no módulo que você deseja. depois é só você selecionar aonde você quer que o(s) bloco(s) apareça. é isso que você queria?

módulos sem os blocos da esquerda

pessoal, pensando em quem usa 800x600, queria saber se não existe um meio de fazer os blocos da esquerda ficarem ocultos em determinados módulos. por exemplo no forum pois raramente alguém passaria do forum para web_links ou uploader. e mesmo assim, provavelmente seria possivel criar um menu horizontal logo abaixo do cabeçalho do portal (como em muitos tema para os *nukes) eu uso a resolução de 1280x960, so que nem todo mundo usa essa resolução e usar menus laterais no fórum é algo que eu não estou querendo muito no meu site. (seja ele re-feito em *nuke ou em phpbb ou xoops)